aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/templates/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/templates/CMakeLists.txt')
-rw-r--r--src/imports/templates/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/imports/templates/CMakeLists.txt b/src/imports/templates/CMakeLists.txt
new file mode 100644
index 00000000..8d94297b
--- /dev/null
+++ b/src/imports/templates/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from templates.pro.
+
+#####################################################################
+## qtquicktemplates2plugin Plugin:
+#####################################################################
+
+add_qml_module(qtquicktemplates2plugin
+ CPP_PLUGIN
+ TARGET_PATH "QtQuick/Templates.2"
+ URI "QtQuick.Templates"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ RESOURCE_PREFIX "/qt-project.org/imports"
+ SOURCES
+ qtquicktemplates2plugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:templates.pro:<TRUE>:
+# CONFIG = "no_cxx_module"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir"
+# TARGETPATH = "QtQuick/Templates.2"
+# _LOADED = "qml_plugin"