aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 3 insertions, 9 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d21be56a..22141371 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,13 +1,7 @@
# Generated from tests.pro.
-if(NOT TARGET Qt::Test)
- cmake_minimum_required(VERSION 3.15.0)
- project(QtQuickControls2Tests VERSION 6.0.0 LANGUAGES C CXX)
- find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS
- BuildInternals Core Qml Quick QmlDevTools QmlDebug QuickTest # special case
- QuickControls2 QuickTemplates2 # special case
- )
- qt_set_up_standalone_tests_build()
+if(QT_BUILD_STANDALONE_TESTS)
+ # Add qt_find_package calls for extra dependencies that need to be found when building
+ # the standalone tests here.
endif()
qt_build_tests()
-