aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quickcontrols2/styleimports
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quickcontrols2/styleimports')
-rw-r--r--tests/auto/quickcontrols2/styleimports/CMakeLists.txt66
-rw-r--r--tests/auto/quickcontrols2/styleimports/ResourceStyle/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/Action.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/qmldir2
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/Label.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+linux/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+macos/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+windows/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/PlatformStyle/Button.qml4
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/PlatformStyle/qmldir2
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/applicationWindowWithButton.qml64
-rw-r--r--tests/auto/quickcontrols2/styleimports/data/qmldir4
-rw-r--r--tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/Button.qml9
-rw-r--r--tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/qmldir2
-rw-r--r--tests/auto/quickcontrols2/styleimports/tst_styleimports.cpp250
17 files changed, 0 insertions, 435 deletions
diff --git a/tests/auto/quickcontrols2/styleimports/CMakeLists.txt b/tests/auto/quickcontrols2/styleimports/CMakeLists.txt
deleted file mode 100644
index 67012c1d..00000000
--- a/tests/auto/quickcontrols2/styleimports/CMakeLists.txt
+++ /dev/null
@@ -1,66 +0,0 @@
-# Generated from styleimports.pro.
-
-#####################################################################
-## tst_styleimports Test:
-#####################################################################
-
-# Collect test data
-file(GLOB_RECURSE test_data_glob
- RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- data/*)
-list(APPEND test_data ${test_data_glob})
-
-qt_internal_add_test(tst_styleimports
- SOURCES
- ../shared/qtest_quickcontrols.h
- ../shared/util.cpp ../shared/util.h
- ../shared/visualtestutil.cpp ../shared/visualtestutil.h
- tst_styleimports.cpp
- DEFINES
- QQC2_IMPORT_PATH=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/quickcontrols2\\\"
- PUBLIC_LIBRARIES
- Qt::CorePrivate
- Qt::Gui
- Qt::GuiPrivate
- Qt::QmlPrivate
- Qt::QuickControls2
- Qt::QuickControls2ImplPrivate
- Qt::QuickControls2Private
- Qt::QuickPrivate
- Qt::QuickTemplates2Private
- Qt::QuickTest
- Qt::TestPrivate
- TESTDATA ${test_data}
-)
-
-# Resources:
-set(qmake_resourcestyle_resource_files
- "resources/ResourceStyle/Button.qml"
- "resources/ResourceStyle/qmldir"
-)
-
-qt_internal_add_resource(tst_styleimports "qmake_resourcestyle"
- PREFIX
- "/"
- BASE
- "resources"
- FILES
- ${qmake_resourcestyle_resource_files}
-)
-
-
-#### Keys ignored in scope 1:.:.:styleimports.pro:<TRUE>:
-# OTHER_FILES = "data/*.qml" "data/qmldir" "data/FileSystemStyle/*.qml" "data/FileSystemStyle/qmldir" "data/PlatformStyle/*.qml" "data/PlatformStyle/+linux/*.qml" "data/PlatformStyle/+macos/*.qml" "data/PlatformStyle/+windows/*.qml" "data/PlatformStyle/qmldir"
-
-## Scopes:
-#####################################################################
-
-qt_internal_extend_target(tst_styleimports CONDITION ANDROID OR IOS
- DEFINES
- QT_QMLTEST_DATADIR=\\\":/data\\\"
-)
-
-qt_internal_extend_target(tst_styleimports CONDITION NOT ANDROID AND NOT IOS
- DEFINES
- QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
-)
diff --git a/tests/auto/quickcontrols2/styleimports/ResourceStyle/Button.qml b/tests/auto/quickcontrols2/styleimports/ResourceStyle/Button.qml
deleted file mode 100644
index 656b27a7..00000000
--- a/tests/auto/quickcontrols2/styleimports/ResourceStyle/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "ResourceStyle"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/Action.qml b/tests/auto/quickcontrols2/styleimports/data/Action.qml
deleted file mode 100644
index f49c6ff4..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/Action.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Action {
- objectName: "data"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/Button.qml b/tests/auto/quickcontrols2/styleimports/data/Button.qml
deleted file mode 100644
index 85367472..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "data"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/Button.qml b/tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/Button.qml
deleted file mode 100644
index a5078b14..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "FileSystemStyle"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/qmldir b/tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/qmldir
deleted file mode 100644
index 3c401588..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/FileSystemStyle/qmldir
+++ /dev/null
@@ -1,2 +0,0 @@
-module FileSystemStyle
-Button 2.15 Button.qml
diff --git a/tests/auto/quickcontrols2/styleimports/data/Label.qml b/tests/auto/quickcontrols2/styleimports/data/Label.qml
deleted file mode 100644
index 3959dae8..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/Label.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Label {
- objectName: "data"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+linux/Button.qml b/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+linux/Button.qml
deleted file mode 100644
index 15c04d77..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+linux/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "PlatformStyle/+linux"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+macos/Button.qml b/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+macos/Button.qml
deleted file mode 100644
index 6c07ec02..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+macos/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "PlatformStyle/+macos"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+windows/Button.qml b/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+windows/Button.qml
deleted file mode 100644
index 6a94679c..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/+windows/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "PlatformStyle/+windows"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/Button.qml b/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/Button.qml
deleted file mode 100644
index fce35efd..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/Button.qml
+++ /dev/null
@@ -1,4 +0,0 @@
-import QtQuick.Templates as T
-T.Button {
- objectName: "PlatformStyle/Button.qml"
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/qmldir b/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/qmldir
deleted file mode 100644
index ce254517..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/PlatformStyle/qmldir
+++ /dev/null
@@ -1,2 +0,0 @@
-module PlatformStyle
-Button 2.15 Button.qml
diff --git a/tests/auto/quickcontrols2/styleimports/data/applicationWindowWithButton.qml b/tests/auto/quickcontrols2/styleimports/data/applicationWindowWithButton.qml
deleted file mode 100644
index ba6af22c..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/applicationWindowWithButton.qml
+++ /dev/null
@@ -1,64 +0,0 @@
-/****************************************************************************
-**
-** Copyright (C) 2020 The Qt Company Ltd.
-** Contact: https://www.qt.io/licensing/
-**
-** This file is part of the test suite of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:BSD$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see https://www.qt.io/terms-conditions. For further
-** information use the contact form at https://www.qt.io/contact-us.
-**
-** BSD License Usage
-** Alternatively, you may use this file under the terms of the BSD license
-** as follows:
-**
-** "Redistribution and use in source and binary forms, with or without
-** modification, are permitted provided that the following conditions are
-** met:
-** * Redistributions of source code must retain the above copyright
-** notice, this list of conditions and the following disclaimer.
-** * Redistributions in binary form must reproduce the above copyright
-** notice, this list of conditions and the following disclaimer in
-** the documentation and/or other materials provided with the
-** distribution.
-** * Neither the name of The Qt Company Ltd nor the names of its
-** contributors may be used to endorse or promote products derived
-** from this software without specific prior written permission.
-**
-**
-** THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-** "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-** LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-** A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-** OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-** SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-** LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-** DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-** THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-** (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-** OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
-
-import QtQuick
-import QtQuick.Controls
-
-ApplicationWindow {
- title: "Test Application Window"
- width: 400
- height: 400
-
- property alias button: button
-
- Button {
- id: button
- }
-}
diff --git a/tests/auto/quickcontrols2/styleimports/data/qmldir b/tests/auto/quickcontrols2/styleimports/data/qmldir
deleted file mode 100644
index 9e9df940..00000000
--- a/tests/auto/quickcontrols2/styleimports/data/qmldir
+++ /dev/null
@@ -1,4 +0,0 @@
-module data
-Action 2.15 Action.qml
-Button 2.15 Button.qml
-Label 2.15 Label.qml
diff --git a/tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/Button.qml b/tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/Button.qml
deleted file mode 100644
index 3a97e9de..00000000
--- a/tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/Button.qml
+++ /dev/null
@@ -1,9 +0,0 @@
-import QtQuick.Controls.impl 2.15
-import QtQuick.Templates 2.15 as T
-T.Button {
- objectName: "ResourceStyle"
-
- contentItem: IconLabel {
- color: "salmon"
- }
-}
diff --git a/tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/qmldir b/tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/qmldir
deleted file mode 100644
index 4cb1a835..00000000
--- a/tests/auto/quickcontrols2/styleimports/resources/ResourceStyle/qmldir
+++ /dev/null
@@ -1,2 +0,0 @@
-module ResourceStyle
-Button 2.15 Button.qml
diff --git a/tests/auto/quickcontrols2/styleimports/tst_styleimports.cpp b/tests/auto/quickcontrols2/styleimports/tst_styleimports.cpp
deleted file mode 100644
index fe5148ed..00000000
--- a/tests/auto/quickcontrols2/styleimports/tst_styleimports.cpp
+++ /dev/null
@@ -1,250 +0,0 @@
-/****************************************************************************
-**
-** Copyright (C) 2017 The Qt Company Ltd.
-** Contact: http://www.qt.io/licensing/
-**
-** This file is part of the test suite of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:LGPL3$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see http://www.qt.io/terms-conditions. For further
-** information use the contact form at http://www.qt.io/contact-us.
-**
-** GNU Lesser General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU Lesser
-** General Public License version 3 as published by the Free Software
-** Foundation and appearing in the file LICENSE.LGPLv3 included in the
-** packaging of this file. Please review the following information to
-** ensure the GNU Lesser General Public License version 3 requirements
-** will be met: https://www.gnu.org/licenses/lgpl.html.
-**
-** GNU General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU
-** General Public License version 2.0 or later as published by the Free
-** Software Foundation and appearing in the file LICENSE.GPL included in
-** the packaging of this file. Please review the following information to
-** ensure the GNU General Public License version 2.0 requirements will be
-** met: http://www.gnu.org/licenses/gpl-2.0.html.
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
-
-#include <QtCore/qregularexpression.h>
-#include <QtTest/qtest.h>
-#include <QtQml/qqmlcomponent.h>
-#include <QtQml/qqmlcontext.h>
-#include <QtQml/qqmlapplicationengine.h>
-#include <QtQml/qqmlengine.h>
-#include <QtQuick/qquickwindow.h>
-#include <QtQuickControls2/qquickstyle.h>
-#include <QtQuickControls2/private/qquickstyle_p.h>
-#include <QtQuickControls2Impl/private/qquickiconlabel_p.h>
-
-#include "../shared/util.h"
-
-class tst_StyleImports : public QQmlDataTest
-{
- Q_OBJECT
-
-private slots:
- void initTestCase() override;
-
- void cleanup();
-
- void select_data();
- void select();
-
- void platformSelectors();
-
- void fallbackStyleShouldNotOverwriteTheme_data();
- void fallbackStyleShouldNotOverwriteTheme();
-};
-
-void tst_StyleImports::initTestCase()
-{
- QQmlDataTest::initTestCase();
-}
-
-void tst_StyleImports::cleanup()
-{
- qmlClearTypeRegistrations();
-}
-
-void tst_StyleImports::select_data()
-{
- QTest::addColumn<QString>("file");
- QTest::addColumn<QString>("style");
- QTest::addColumn<QString>("fallback");
- QTest::addColumn<QString>("expected");
-
- // Action.qml exists in the "data" style and the Basic style.
- QTest::newRow("control=Action,style=basic,fallback=empty") << "Action.qml" << "Basic" << "" << "Basic";
- QTest::newRow("control=Action,style=fs,fallback=empty") << "Action.qml" << "FileSystemStyle" << "" << "Basic";
- QTest::newRow("control=Action,style=qrc,fallback=empty") << "Action.qml" << "ResourceStyle" << "" << "Basic";
- QTest::newRow("control=Action,style=nosuch,fallback=empty") << "Action.qml" << "NoSuchStyle" << "" << "Basic";
- QTest::newRow("control=Action,style=data,fallback=empty") << "Action.qml" << "data" << "" << "data";
-
- QTest::newRow("control=Action,style=basic,fallback=mat") << "Action.qml" << "Basic" << "Material" << "";
- QTest::newRow("control=Action,style=fs,fallback=mat") << "Action.qml" << "FileSystemStyle" << "Material" << "Basic";
- QTest::newRow("control=Action,style=qrc,fallback=mat") << "Action.qml" << "ResourceStyle" << "Material" << "Basic";
- QTest::newRow("control=Action,style=nosuch,fallback=mat") << "Action.qml" << "NoSuchStyle" << "Material" << "Basic";
- QTest::newRow("control=Action,style=data,fallback=mat") << "Action.qml" << "data" << "Material" << "data";
-
- // Amongst the styles we're testing here, ScrollView.qml only exists in the Basic style.
- QTest::newRow("control=ScrollView,style=basic,fallback=empty") << "ScrollView.qml" << "Basic" << "" << "Basic";
- QTest::newRow("control=ScrollView,style=fs,fallback=empty") << "ScrollView.qml" << "FileSystemStyle" << "" << "Basic";
- QTest::newRow("control=ScrollView,style=qrc,fallback=empty") << "ScrollView.qml" << "ResourceStyle" << "" << "Basic";
- QTest::newRow("control=ScrollView,style=nosuch,fallback=empty") << "ScrollView.qml" << "NoSuchStyle" << "" << "Basic";
- QTest::newRow("control=ScrollView,style=data,fallback=empty") << "ScrollView.qml" << "data" << "" << "Basic";
-
- QTest::newRow("control=ScrollView,style=basic,fallback=mat") << "ScrollView.qml" << "Basic" << "Material" << "Basic";
- QTest::newRow("control=ScrollView,style=fs,fallback=mat") << "ScrollView.qml" << "FileSystemStyle" << "Material" << "Basic";
- QTest::newRow("control=ScrollView,style=qrc,fallback=mat") << "ScrollView.qml" << "ResourceStyle" << "Material" << "Basic";
- QTest::newRow("control=ScrollView,style=nosuch,fallback=mat") << "ScrollView.qml" << "NoSuchStyle" << "Material" << "Basic";
- QTest::newRow("control=ScrollView,style=data,fallback=mat") << "ScrollView.qml" << "data" << "Material" << "Basic";
-
- // Label.qml exists in the "data", Basic and Material styles.
- QTest::newRow("control=Label,style=basic,fallback=empty") << "Label.qml" << "Basic" << "" << "Basic";
- QTest::newRow("control=Label,style=fs,fallback=empty") << "Label.qml" << "FileSystemStyle" << "" << "Basic";
- QTest::newRow("control=Label,style=qrc,fallback=empty") << "Label.qml" << "ResourceStyle" << "" << "Basic";
- QTest::newRow("control=Label,style=nosuch,fallback=empty") << "Label.qml" << "NoSuchStyle" << "" << "Basic";
- QTest::newRow("control=Label,style=data,fallback=empty") << "Label.qml" << "data" << "" << "data";
-
- QTest::newRow("control=Label,style=basic,fallback=mat") << "Label.qml" << "Basic" << "Material" << "Basic";
- QTest::newRow("control=Label,style=fs,fallback=mat") << "Label.qml" << "FileSystemStyle" << "Material" << "Basic";
- QTest::newRow("control=Label,style=qrc,fallback=mat") << "Label.qml" << "ResourceStyle" << "Material" << "Basic";
- QTest::newRow("control=Label,style=nosuch,fallback=mat") << "Label.qml" << "NoSuchStyle" << "Material" << "Basic";
- QTest::newRow("control=Label,style=data,fallback=mat") << "Label.qml" << "data" << "Material" << "data";
-
- // Button.qml exists in all styles including the fs and qrc styles
- QTest::newRow("control=Button,style=basic,fallback=empty") << "Button.qml" << "Basic" << "" << "Basic";
- QTest::newRow("control=Button,style=fs,fallback=empty") << "Button.qml" << "FileSystemStyle" << "" << "FileSystemStyle";
- QTest::newRow("control=Button,style=qrc,fallback=empty") << "Button.qml" << "ResourceStyle" << "" << "ResourceStyle";
- QTest::newRow("control=Button,style=nosuch,fallback=empty") << "Button.qml" << "NoSuchStyle" << "" << "Basic";
- QTest::newRow("control=Button,style=data,fallback=empty") << "Button.qml" << "data" << "" << "data";
-
- QTest::newRow("control=Button,style=basic,fallback=mat") << "Button.qml" << "Basic" << "Material" << "Basic";
- QTest::newRow("control=Button,style=fs,fallback=mat") << "Button.qml" << "FileSystemStyle" << "Material" << "FileSystemStyle";
- QTest::newRow("control=Button,style=qrc,fallback=mat") << "Button.qml" << "ResourceStyle" << "Material" << "ResourceStyle";
- QTest::newRow("control=Button,style=nosuch,fallback=mat") << "Button.qml" << "NoSuchStyle" << "Material" << "Basic";
- QTest::newRow("control=Button,style=data,fallback=mat") << "Button.qml" << "data" << "Material" << "data";
-}
-
-void tst_StyleImports::select()
-{
- QFETCH(QString, file);
- QFETCH(QString, style);
- QFETCH(QString, fallback);
- QFETCH(QString, expected);
-
- // In Qt 5, there were several accepted forms for style names.
- // In Qt 6, the only accepted form is the base name of the style directory.
- const bool invalidStyleName = style.contains(QLatin1Char('/'));
- if (invalidStyleName)
- QTest::ignoreMessage(QtWarningMsg,
- "Style names must not contain paths; see the \"Definition of a Style\" documentation for more information");
- QQuickStyle::setStyle(style);
- QQuickStyle::setFallbackStyle(fallback);
-
- QQmlEngine engine;
- engine.addImportPath(QLatin1String(":/"));
- engine.addImportPath(directory());
- engine.addImportPath(dataDirectory());
- QQmlComponent component(&engine);
- const QString controlName = file.mid(0, file.indexOf(QLatin1Char('.')));
- component.setData(QString::fromLatin1("import QtQuick; import QtQuick.Controls; %1 { }").arg(controlName).toUtf8(), QUrl());
-
- const bool nonExistentStyle = style == QLatin1String("NoSuchStyle");
- if (nonExistentStyle)
- QTest::ignoreMessage(QtWarningMsg, "QQmlComponent: Component is not ready");
- QScopedPointer<QObject> object(component.create());
- if (nonExistentStyle) {
- QVERIFY(object.isNull());
- return;
- }
-
- QVERIFY2(!object.isNull(), qPrintable(component.errorString()));
-
- // TODO: test built-in styles below too
- // We can't check for the attached style object since that API is in a plugin,
- // and it's not possible to use e.g. the baseUrl of the QQmlContext
- // nor the metaObject to test it either.
-
- if (!QQuickStylePrivate::builtInStyles().contains(expected)) {
- // We're expecting a custom style.
- QCOMPARE(object->objectName(), expected);
- }
-}
-
-void tst_StyleImports::platformSelectors()
-{
- QQuickStyle::setStyle(QLatin1String("PlatformStyle"));
-
- QQmlApplicationEngine engine;
- engine.addImportPath(dataDirectory());
- engine.load(testFileUrl("applicationWindowWithButton.qml"));
- QQuickWindow *window = qobject_cast<QQuickWindow*>(engine.rootObjects().first());
- QVERIFY(window);
-
- QObject *button = window->property("button").value<QObject*>();
- QVERIFY(button);
-
-#if defined(Q_OS_LINUX)
- QCOMPARE(button->objectName(), "PlatformStyle/+linux");
-#elif defined(Q_OS_MACOS)
- QCOMPARE(button->objectName(), "PlatformStyle/+macos");
-#elif defined(Q_OS_WIN)
- QCOMPARE(button->objectName(), "PlatformStyle/+windows");
-#else
- QCOMPARE(button->objectName(), "PlatformStyle/Button.qml");
-#endif
-}
-
-void tst_StyleImports::fallbackStyleShouldNotOverwriteTheme_data()
-{
- QTest::addColumn<QString>("style");
- QTest::addColumn<QString>("fallbackStyle");
- QTest::addColumn<QColor>("expectedContentItemColor");
-
- QTest::addRow("style=Fusion,fallbackStyle=Material")
- << QString::fromLatin1("Fusion") << QString::fromLatin1("Material") << QColor::fromRgb(0x252525);
- QTest::addRow("style=ResourceStyle,fallbackStyle=Material")
- << QString::fromLatin1("ResourceStyle") << QString::fromLatin1("Material") << QColor("salmon");
-}
-
-void tst_StyleImports::fallbackStyleShouldNotOverwriteTheme()
-{
- QFETCH(QString, style);
- QFETCH(QString, fallbackStyle);
- QFETCH(QColor, expectedContentItemColor);
-
- QQuickStyle::setStyle(style);
- QQuickStyle::setFallbackStyle(fallbackStyle);
-
- QQmlApplicationEngine engine;
- engine.addImportPath(QLatin1String(":/"));
- engine.addImportPath(dataDirectory());
- engine.load(testFileUrl("applicationWindowWithButton.qml"));
- QVERIFY(!engine.rootObjects().isEmpty());
- QQuickWindow *window = qobject_cast<QQuickWindow*>(engine.rootObjects().first());
- QVERIFY(window);
-
- QObject *button = window->property("button").value<QObject*>();
- QVERIFY(button);
-
- QQuickIconLabel *contentItem = button->property("contentItem").value<QQuickIconLabel*>();
- QVERIFY(contentItem);
-
- // For example: the Fusion style provides Button.qml, so the Button's text color
- // should be that of QPalette::ButtonText from QQuickFusionTheme.
- QCOMPARE(contentItem->color(), expectedContentItemColor);
-}
-
-QTEST_MAIN(tst_StyleImports)
-
-#include "tst_styleimports.moc"