summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-01-18 12:53:22 +0200
committerJuha Vuolle <juha.vuolle@insta.fi>2021-01-21 16:45:25 +0200
commitedc37027f438a76eb6286935def71fa721e5eb15 (patch)
tree191ff2fa53d6880a501d3ac95444aa21292f5b6f /CMakeLists.txt
parent9eb96602f9667de6c777566760a06ea8324c6c06 (diff)
QtScxml module cmake port
Task-number: QTBUG-89828 Change-Id: I95ec7905654bd3eaf61b22082ee1040aba4b9b24 Reviewed-by: Karsten Heimrich <karsten.heimrich@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a121516..533e26c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,18 +1,16 @@
# Generated from qtscxml.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtScxml
VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt Scxml Libraries"
+ DESCRIPTION "Qt Scxml and StateMachine libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-# special case begin
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Gui)
-# special case end
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Qml Widgets Quick OpenGL OpenGLWidgets)
qt_build_repo()