summaryrefslogtreecommitdiffstats
path: root/src/imports/scxmlstatemachine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/scxmlstatemachine/CMakeLists.txt')
-rw-r--r--src/imports/scxmlstatemachine/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/imports/scxmlstatemachine/CMakeLists.txt b/src/imports/scxmlstatemachine/CMakeLists.txt
new file mode 100644
index 0000000..f0218cd
--- /dev/null
+++ b/src/imports/scxmlstatemachine/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from scxmlstatemachine.pro.
+
+#####################################################################
+## scxml Plugin:
+#####################################################################
+
+qt_add_qml_module(declarative_scxml # special case
+ URI "QtScxml"
+ VERSION "5.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QScxmlStateMachinePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ eventconnection.cpp eventconnection_p.h
+ invokedservices.cpp invokedservices_p.h
+ plugin.cpp
+ statemachineextended.cpp statemachineextended_p.h
+ statemachineloader.cpp statemachineloader_p.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::Scxml
+)
+
+#### Keys ignored in scope 1:.:.:scxmlstatemachine.pro:<TRUE>:
+# IMPORT_VERSION = "5.$$QT_MINOR_VERSION"
+# OTHER_FILES = "plugins.qmltypes" "qmldir"
+# TARGETPATH = "QtScxml"