summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_qtscxml_module/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_qtscxml_module/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_qtscxml_module/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_qtscxml_module/CMakeLists.txt b/tests/auto/cmake/test_qtscxml_module/CMakeLists.txt
new file mode 100644
index 0000000..e2cf03a
--- /dev/null
+++ b/tests/auto/cmake/test_qtscxml_module/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(test_qtscxml_module)
+
+find_package(Qt5Scxml REQUIRED)
+
+set(MAIN_SRCS main.cpp)
+qt5_add_statecharts(MAIN_SRCS
+ ../../compiled/connection.scxml
+
+ # unused, just for testing whether it's possible to pass multiple files
+ ../../compiled/topmachine.scxml
+)
+add_executable(mainapp ${MAIN_SRCS})
+target_include_directories(mainapp PRIVATE ${CMAKE_CURRENT_BINARY_DIR})
+target_link_libraries(mainapp Qt5::Scxml)