summaryrefslogtreecommitdiffstats
path: root/tests/auto/qmltest/scxml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmltest/scxml/CMakeLists.txt')
-rw-r--r--tests/auto/qmltest/scxml/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/qmltest/scxml/CMakeLists.txt b/tests/auto/qmltest/scxml/CMakeLists.txt
new file mode 100644
index 0000000..64bec63
--- /dev/null
+++ b/tests/auto/qmltest/scxml/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/tst_*)
+list(APPEND test_data ${test_data_glob})
+
+qt_internal_add_test(tst_scxmlqml
+ GUI
+ QMLTEST
+ SOURCES
+ tst_scxmlqml.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ TESTDATA ${test_data}
+)
+
+# Resources:
+set(tst_scxmlqml_resource_files
+ "statemachine.scxml"
+)
+
+qt_internal_add_resource(tst_scxmlqml "tst_scxmlqml"
+ PREFIX
+ "/"
+ FILES
+ ${tst_scxmlqml_resource_files}
+)