summaryrefslogtreecommitdiffstats
path: root/src/imports/sensors/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-05-21 10:01:56 +0300
committerJuha Vuolle <juha.vuolle@insta.fi>2021-05-26 09:48:04 +0300
commit0193d164e79845f7a2b5a388ed2818854c77399f (patch)
tree68d05a426a53d39c0bce34705dd91fbbbc9c24e5 /src/imports/sensors/CMakeLists.txt
parentcf21f9074be72e9d5a1c45638bf6762edad7a73f (diff)
Split the Sensors QML plugin into a library and a plugin
The main changes: - Introduction of new SensorsQuick library with private exports - The original QML plugin loads this new library and does little else - Renamed original 'sensors' plugin as 'declarative_sensors' to provide an idea what it relates to - Renamed library headers as private "_p.h" and added "We mean it" - Changed qmlRegister* calls to QML_ELEMENT macros - Removed files that are generated in Qt6 (qmldir, plugins.qmltypes) Task-number: QTBUG-92530 Change-Id: I18f849adabcc79ac47e67305f78aefeee82801bc Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/sensors/CMakeLists.txt')
-rw-r--r--src/imports/sensors/CMakeLists.txt36
1 files changed, 4 insertions, 32 deletions
diff --git a/src/imports/sensors/CMakeLists.txt b/src/imports/sensors/CMakeLists.txt
index 87414bde..d20add31 100644
--- a/src/imports/sensors/CMakeLists.txt
+++ b/src/imports/sensors/CMakeLists.txt
@@ -1,42 +1,14 @@
-
-# TODO Qt 6.2 split into separate QML library + plugin
-
-qt_internal_add_qml_module(sensors
+qt_internal_add_qml_module(declarative_sensors
URI "QtSensors"
- VERSION "${CMAKE_PROJECT_VERSION}"
+ VERSION "${PROJECT_VERSION}"
CLASSNAME QtSensorsDeclarativeModule
SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL
SOURCES
- qmlaccelerometer.cpp qmlaccelerometer.h
- qmlaltimeter.cpp qmlaltimeter.h
- qmlambientlightsensor.cpp qmlambientlightsensor.h
- qmlambienttemperaturesensor.cpp qmlambienttemperaturesensor.h
- qmlcompass.cpp qmlcompass.h
- qmldistancesensor.cpp qmldistancesensor.h
- qmlgyroscope.cpp qmlgyroscope.h
- qmlholstersensor.cpp qmlholstersensor.h
- qmlhumiditysensor.cpp qmlhumiditysensor.h
- qmlirproximitysensor.cpp qmlirproximitysensor.h
- qmllidsensor.cpp qmllidsensor.h
- qmllightsensor.cpp qmllightsensor.h
- qmlmagnetometer.cpp qmlmagnetometer.h
- qmlorientationsensor.cpp qmlorientationsensor.h
- qmlpressuresensor.cpp qmlpressuresensor.h
- qmlproximitysensor.cpp qmlproximitysensor.h
- qmlrotationsensor.cpp qmlrotationsensor.h
- qmlsensor.cpp qmlsensor.h
- qmlsensorgesture.cpp qmlsensorgesture.h
- qmlsensorglobal.cpp qmlsensorglobal.h
- qmlsensorrange.cpp qmlsensorrange.h
- qmltapsensor.cpp qmltapsensor.h
- qmltiltsensor.cpp qmltiltsensor.h
sensors.cpp
PUBLIC_LIBRARIES
Qt::Core
- Qt::Gui
Qt::Qml
- Qt::Sensors
LIBRARIES
- Qt::CorePrivate
- Qt::SensorsPrivate
+ Qt::SensorsQuickPrivate
)