summaryrefslogtreecommitdiffstats
path: root/tests/manual/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-04-29 11:23:04 +0300
committerJuha Vuolle <juha.vuolle@insta.fi>2021-04-30 11:48:31 +0300
commitf828d901eeb539a2756ea4c0cb613d55d04ca8e6 (patch)
tree1e840d8c0408be8ebf67e458f95fb31556de2566 /tests/manual/CMakeLists.txt
parentb16b1e36dae0a5b3203bb671b4f87ce4b0bfe009 (diff)
Enable QtSensors manual tests as part of build
The two manual test applications are now part of build when manual tests are built. This helps to detect if the test applications break over time. The tests were slightly renamed to avoid a naming clash with an example app. In addition the commit addresses few trivial things so that the applications start and run without warnings. Task-number: QTBUG-92502 Change-Id: Ia0368764102efc16276116bc8c75d562d79c1e27 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/manual/CMakeLists.txt')
-rw-r--r--tests/manual/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
new file mode 100644
index 00000000..bc8b1f30
--- /dev/null
+++ b/tests/manual/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(TARGET Qt::Widgets)
+ add_subdirectory(sensor_explorer)
+endif()
+if (TARGET Qt::Quick)
+ add_subdirectory(sensorclerk)
+endif()