summaryrefslogtreecommitdiffstats
path: root/examples/sensors/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sensors/CMakeLists.txt')
-rw-r--r--examples/sensors/CMakeLists.txt19
1 files changed, 5 insertions, 14 deletions
diff --git a/examples/sensors/CMakeLists.txt b/examples/sensors/CMakeLists.txt
index 7fe6c4e9..bf1120c8 100644
--- a/examples/sensors/CMakeLists.txt
+++ b/examples/sensors/CMakeLists.txt
@@ -1,15 +1,6 @@
-if(TARGET Qt::Quick)
- add_subdirectory(grue)
- add_subdirectory(maze)
-# add_subdirectory(qmlsensorgestures)
- add_subdirectory(qmlqtsensors)
- add_subdirectory(sensor_explorer)
-# add_subdirectory(shakeit)
- if(TARGET Qt::Svg)
- add_subdirectory(accelbubble)
- add_subdirectory(sensorsshowcase)
- endif()
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+if(TARGET Qt::Quick AND TARGET Qt::Svg)
+ qt_internal_add_example(sensorsshowcase)
endif()
-# if(TARGET Qt::Widgets)
-# add_subdirectory(sensorgestures)
-# endif()