summaryrefslogtreecommitdiffstats
path: root/src/plugins/sensors/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/sensors/CMakeLists.txt')
-rw-r--r--src/plugins/sensors/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/plugins/sensors/CMakeLists.txt b/src/plugins/sensors/CMakeLists.txt
index 7b11ea7f..e7527d8f 100644
--- a/src/plugins/sensors/CMakeLists.txt
+++ b/src/plugins/sensors/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# all get generic sensor
add_subdirectory(generic)
@@ -22,6 +25,6 @@ if(LINUX AND TARGET Qt::DBus AND NOT SENSORS_PLUGINS OR "iio-sensor-proxy" IN_LI
add_subdirectory(iio-sensor-proxy)
endif()
-if(NOT SENSORS_PLUGINS OR "dummy" IN_LIST SENSORS_PLUGINS)
+if("dummy" IN_LIST SENSORS_PLUGINS)
add_subdirectory(dummy)
endif()