summaryrefslogtreecommitdiffstats
path: root/examples/serialbus/modbus/custom/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/serialbus/modbus/custom/CMakeLists.txt')
-rw-r--r--examples/serialbus/modbus/custom/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/examples/serialbus/modbus/custom/CMakeLists.txt b/examples/serialbus/modbus/custom/CMakeLists.txt
index 21c50ad..e9e676a 100644
--- a/examples/serialbus/modbus/custom/CMakeLists.txt
+++ b/examples/serialbus/modbus/custom/CMakeLists.txt
@@ -1,23 +1,16 @@
cmake_minimum_required(VERSION 3.16)
project(customcommand LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/serialbus/modbus/custom")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Network)
-find_package(Qt6 COMPONENTS SerialBus)
-find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Network SerialBus Widgets)
qt_add_executable(customcommand
main.cpp