summaryrefslogtreecommitdiffstats
path: root/examples/serialport/blockingreceiver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/serialport/blockingreceiver/CMakeLists.txt')
-rw-r--r--examples/serialport/blockingreceiver/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/serialport/blockingreceiver/CMakeLists.txt b/examples/serialport/blockingreceiver/CMakeLists.txt
index e835de82..25088dd5 100644
--- a/examples/serialport/blockingreceiver/CMakeLists.txt
+++ b/examples/serialport/blockingreceiver/CMakeLists.txt
@@ -1,11 +1,9 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
cmake_minimum_required(VERSION 3.16)
project(blockingreceiver LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/serialport/blockingreceiver")
find_package(Qt6 REQUIRED COMPONENTS Core Gui SerialPort Widgets)
+qt_standard_project_setup()
+
qt_add_executable(blockingreceiver
dialog.cpp dialog.h
main.cpp