summaryrefslogtreecommitdiffstats
path: root/tests/manual/examples/receiver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/examples/receiver/CMakeLists.txt')
-rw-r--r--tests/manual/examples/receiver/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/manual/examples/receiver/CMakeLists.txt b/tests/manual/examples/receiver/CMakeLists.txt
new file mode 100644
index 00000000..b50166ee
--- /dev/null
+++ b/tests/manual/examples/receiver/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(receiver LANGUAGES CXX)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui SerialPort Widgets)
+
+qt_standard_project_setup()
+
+qt_add_executable(receiver
+ dialog.cpp dialog.h
+ main.cpp
+)
+
+set_target_properties(receiver PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(receiver PRIVATE
+ Qt::Core
+ Qt::Gui
+ Qt::SerialPort
+ Qt::Widgets
+)