summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 8de2eb4..1471daa 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -8,3 +8,9 @@ endif()
add_subdirectory(qshaderbaker)
add_subdirectory(buildtimeqsb)
+
+_qt_internal_check_depfile_support(has_depfile_support)
+if(has_depfile_support AND NOT CMAKE_CROSSCOMPILING)
+ # The test is disabled for cross-compiling platforms since we cannot embed the test results.
+ add_subdirectory(qsbdepfiles)
+endif()