summaryrefslogtreecommitdiffstats
path: root/examples/speech/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2022-04-05 11:55:58 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2022-04-07 12:24:58 +0200
commit952107c475bc6d8d0ae50542776b73500b5c81c7 (patch)
tree15c219424ffd47f0bfe051bf8be0c4ab5c01552f /examples/speech/CMakeLists.txt
parentd4495a745ba565aa3f5c86ef7d84118c716222b6 (diff)
Build documentation
Fix the CMakeLists file to point at the qdocconf file, and remove the qmake .pro file. The only module in the repository is the TextToSpeech module, so the documentation needs to live in the directory releative to that. This makes qdoc generate the documentation correctly, and without warnings. Change-Id: I4406ec5656641b46ec9d9bc154bc8dd10b271d3b Reviewed-by: Jarkko Koivikko <jarkko.koivikko@code-q.fi> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/speech/CMakeLists.txt')
-rw-r--r--examples/speech/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/speech/CMakeLists.txt b/examples/speech/CMakeLists.txt
index e66e7a0..a031b4c 100644
--- a/examples/speech/CMakeLists.txt
+++ b/examples/speech/CMakeLists.txt
@@ -1,5 +1,5 @@
# Generated from speech.pro.
if(TARGET Qt::Widgets)
- add_subdirectory(hello_speak)
+ qt_internal_add_example(hello_speak)
endif()