summaryrefslogtreecommitdiffstats
path: root/src/plugins/tts/macos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tts/macos/CMakeLists.txt')
-rw-r--r--src/plugins/tts/macos/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/plugins/tts/macos/CMakeLists.txt b/src/plugins/tts/macos/CMakeLists.txt
new file mode 100644
index 0000000..af39feb
--- /dev/null
+++ b/src/plugins/tts/macos/CMakeLists.txt
@@ -0,0 +1,12 @@
+qt_internal_add_plugin(QTextToSpeechMacOSPlugin
+ OUTPUT_NAME qtexttospeech_speech_macos
+ PLUGIN_TYPE texttospeech
+ SOURCES
+ qtexttospeech_macos.h qtexttospeech_macos.mm
+ qtexttospeech_macos_plugin.cpp qtexttospeech_macos_plugin.h
+ LIBRARIES
+ ${FWCocoa}
+ Qt::Core
+ Qt::Gui
+ Qt::TextToSpeech
+)