summaryrefslogtreecommitdiffstats
path: root/src/plugins/tts/osx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tts/osx/CMakeLists.txt')
-rw-r--r--src/plugins/tts/osx/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/tts/osx/CMakeLists.txt b/src/plugins/tts/osx/CMakeLists.txt
new file mode 100644
index 0000000..578f829
--- /dev/null
+++ b/src/plugins/tts/osx/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from osx.pro.
+
+#####################################################################
+## qtexttospeech_speechosx Plugin:
+#####################################################################
+
+add_qt_plugin(qtexttospeech_speechosx
+ TYPE texttospeech
+ CLASS_NAME QTextToSpeechPluginOsx
+ SOURCES
+ qtexttospeech_osx.h qtexttospeech_osx.mm
+ qtexttospeech_osx_plugin.cpp qtexttospeech_osx_plugin.h
+ PUBLIC_LIBRARIES
+ ${FWCocoa}
+ Qt::Core
+ Qt::Gui
+ Qt::TextToSpeech
+)
+
+#### Keys ignored in scope 1:.:.:osx.pro:<TRUE>:
+# OTHER_FILES = "osx_plugin.json"
+# PLUGIN_CLASS_NAME = "QTextToSpeechPluginOsx"
+# PLUGIN_TYPE = "texttospeech"
+# _LOADED = "qt_plugin"