summaryrefslogtreecommitdiffstats
path: root/src/plugins/tts/speechdispatcher/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tts/speechdispatcher/CMakeLists.txt')
-rw-r--r--src/plugins/tts/speechdispatcher/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/plugins/tts/speechdispatcher/CMakeLists.txt b/src/plugins/tts/speechdispatcher/CMakeLists.txt
new file mode 100644
index 0000000..179815b
--- /dev/null
+++ b/src/plugins/tts/speechdispatcher/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from speechdispatcher.pro.
+
+#####################################################################
+## qtexttospeech_speechd Plugin:
+#####################################################################
+
+add_qt_plugin(qtexttospeech_speechd
+ TYPE texttospeech
+ CLASS_NAME QTextToSpeechPluginSpeechd
+ SOURCES
+ qtexttospeech_speechd.cpp qtexttospeech_speechd.h
+ qtexttospeech_speechd_plugin.cpp qtexttospeech_speechd_plugin.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::TextToSpeech
+)
+
+#### Keys ignored in scope 1:.:.:speechdispatcher.pro:<TRUE>:
+# OTHER_FILES = "speechd_plugin.json"
+# PLUGIN_CLASS_NAME = "QTextToSpeechPluginSpeechd"
+# PLUGIN_TYPE = "texttospeech"
+# QT_FOR_CONFIG = "texttospeech-private"
+# _LOADED = "qt_plugin"
+
+## Scopes:
+#####################################################################
+
+extend_target(qtexttospeech_speechd CONDITION QT_FEATURE_speechd
+ LIBRARIES
+ SpeechDispatcher::SpeechDispatcher
+)