summaryrefslogtreecommitdiffstats
path: root/tests/auto/texttospeech/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/texttospeech/CMakeLists.txt')
-rw-r--r--tests/auto/texttospeech/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/auto/texttospeech/CMakeLists.txt b/tests/auto/texttospeech/CMakeLists.txt
new file mode 100644
index 0000000..b9fecf7
--- /dev/null
+++ b/tests/auto/texttospeech/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from texttospeech.pro.
+
+#####################################################################
+## tst_qtexttospeech Test:
+#####################################################################
+
+add_qt_test(tst_qtexttospeech
+ GUI
+ SOURCES
+ tst_qtexttospeech.cpp
+ LIBRARIES
+ Qt::TextToSpeechPrivate
+ PUBLIC_LIBRARIES
+ Qt::TextToSpeech
+)
+
+## Scopes:
+#####################################################################
+
+qt_find_package(SpeechDispatcher PROVIDED_TARGETS SpeechDispatcher::SpeechDispatcher) # special case
+extend_target(tst_qtexttospeech CONDITION QT_FEATURE_speechd
+ PUBLIC_LIBRARIES
+ SpeechDispatcher::SpeechDispatcher
+)