summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-04 09:04:41 +0100
committerKai Köhne <kai.koehne@qt.io>2022-01-20 09:24:12 +0100
commitf485079c843ed1d28e7f5546f468f2af94cdec69 (patch)
treeaff121fd34cb3fc8aada233e45e2ce3ecbdd7b3f /CMakeLists.txt
parentad85ee214f9936b6a7b63762612dabc246d80866 (diff)
Compile repo with warnings as errors
Let the compilation fail if new warnings are introduced for developer builds & supported compilers. Pick-to: 6.2 6.3 Change-Id: I45653c1a0576cf7ef27c70bfe07de202e9311df3 Reviewed-by: Topi Reiniö <topi.reinio@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b088ee8b8..171aa099f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,9 +10,6 @@ project(QtTools # special case
LANGUAGES CXX C
)
-# special case begin
-set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-
# add platform specific compontents
set(optional_components "")
if(WIN32)
@@ -23,7 +20,6 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Co
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
DBus Xml Widgets Quick QuickWidgets Qml
Sql PrintSupport OpenGL OpenGLWidgets ${optional_components})
-# special case end
qt_build_repo()