summaryrefslogtreecommitdiffstats
path: root/src/linguist/linguist/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-18 14:35:40 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-18 16:25:40 +0000
commit3b673994ea0311616db7022cef859705e25cdfab (patch)
tree7e637d7c5df75f121fce53ac8aeb59178e21981c /src/linguist/linguist/CMakeLists.txt
parentd9a3e03934076aea8852f1c4b142a5ecfeea0297 (diff)
CMake: Regenerate projects after mergewip/cmake
Plus additional adjustments. Change-Id: I0c2341ef6a5557e18df91b753f9e441c5b1a68e2 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/linguist/linguist/CMakeLists.txt')
-rw-r--r--src/linguist/linguist/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/linguist/linguist/CMakeLists.txt b/src/linguist/linguist/CMakeLists.txt
index 8d6d42700..4e32082c3 100644
--- a/src/linguist/linguist/CMakeLists.txt
+++ b/src/linguist/linguist/CMakeLists.txt
@@ -16,6 +16,7 @@ qt_add_executable(linguist
../shared/translatormessage.cpp ../shared/translatormessage.h
../shared/ts.cpp
../shared/xliff.cpp
+ ../shared/xmlparser.cpp ../shared/xmlparser.h
batchtranslation.ui
batchtranslationdialog.cpp batchtranslationdialog.h
errorsview.cpp errorsview.h
@@ -46,16 +47,13 @@ qt_add_executable(linguist
QT_NO_CAST_TO_ASCII
INCLUDE_DIRECTORIES
../shared
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::UiToolsPrivate
PUBLIC_LIBRARIES
+ Qt::CorePrivate
Qt::Gui
+ Qt::GuiPrivate
Qt::PrintSupport
- Qt::UiTools
+ Qt::UiToolsPrivate
Qt::Widgets
- Qt::Xml
ENABLE_AUTOGEN_TOOLS
uic
)