summaryrefslogtreecommitdiffstats
path: root/examples/assistant/remotecontrol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/assistant/remotecontrol/CMakeLists.txt')
-rw-r--r--examples/assistant/remotecontrol/CMakeLists.txt23
1 files changed, 12 insertions, 11 deletions
diff --git a/examples/assistant/remotecontrol/CMakeLists.txt b/examples/assistant/remotecontrol/CMakeLists.txt
index 3e4627975..8afd64315 100644
--- a/examples/assistant/remotecontrol/CMakeLists.txt
+++ b/examples/assistant/remotecontrol/CMakeLists.txt
@@ -1,35 +1,36 @@
-# Generated from remotecontrol.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(remotecontrol LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/assistant/remotecontrol")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-add_qt_gui_executable(remotecontrol
+qt_add_executable(remotecontrol
main.cpp
remotecontrol.cpp remotecontrol.h remotecontrol.ui
)
+
+set_target_properties(remotecontrol PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
target_link_libraries(remotecontrol PUBLIC
Qt::Core
Qt::Gui
Qt::Widgets
)
-
# Resources:
set(remotecontrol_resource_files
"enter.png"