summaryrefslogtreecommitdiffstats
path: root/examples/uitools/textfinder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/uitools/textfinder/CMakeLists.txt')
-rw-r--r--examples/uitools/textfinder/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/examples/uitools/textfinder/CMakeLists.txt b/examples/uitools/textfinder/CMakeLists.txt
index 96911c675..21e4f08d5 100644
--- a/examples/uitools/textfinder/CMakeLists.txt
+++ b/examples/uitools/textfinder/CMakeLists.txt
@@ -1,40 +1,40 @@
-# Generated from textfinder.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
cmake_minimum_required(VERSION 3.16)
project(textfinder LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/uitools/textfinder")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS UiTools)
+#! [0]
+find_package(Qt6 REQUIRED COMPONENTS Core Gui UiTools Widgets)
+#! [0]
qt_add_executable(textfinder
main.cpp
textfinder.cpp textfinder.h
)
+
set_target_properties(textfinder PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
+#! [1]
target_link_libraries(textfinder PUBLIC
Qt::Core
Qt::Gui
Qt::UiTools
Qt::Widgets
)
-
+#! [1]
# Resources:
set(textfinder_resource_files