summaryrefslogtreecommitdiffstats
path: root/src/assistant/assistant/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/assistant/assistant/CMakeLists.txt')
-rw-r--r--src/assistant/assistant/CMakeLists.txt20
1 files changed, 4 insertions, 16 deletions
diff --git a/src/assistant/assistant/CMakeLists.txt b/src/assistant/assistant/CMakeLists.txt
index 69470c509..10df7f777 100644
--- a/src/assistant/assistant/CMakeLists.txt
+++ b/src/assistant/assistant/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from assistant.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## assistant App:
@@ -42,13 +43,13 @@ qt_internal_add_app(assistant
xbelsupport.cpp xbelsupport.h
INCLUDE_DIRECTORIES
../../shared/fontpanel
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
Qt::Help
Qt::Network
Qt::Sql
Qt::Widgets
- Qt::PrintSupport # special case
+ Qt::PrintSupport
qlitehtml
ENABLE_AUTOGEN_TOOLS
uic
@@ -61,7 +62,6 @@ set(assistant_images_resource_files
"images/bookmark.png"
"images/closebutton.png"
"images/darkclosebutton.png"
- "images/mac/addtab.png"
"images/mac/book.png"
"images/mac/closetab.png"
"images/mac/editcopy.png"
@@ -74,7 +74,6 @@ set(assistant_images_resource_files
"images/mac/synctoc.png"
"images/mac/zoomin.png"
"images/mac/zoomout.png"
- "images/win/addtab.png"
"images/win/book.png"
"images/win/closetab.png"
"images/win/editcopy.png"
@@ -101,18 +100,9 @@ set_target_properties(assistant PROPERTIES
QT_TARGET_DESCRIPTION "Qt Assistant"
)
-#### Keys ignored in scope 1:.:.:assistant.pro:<TRUE>:
-# PROJECTNAME = "Assistant"
-
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:assistant.pro:TARGET Qt::WebKitWidgets AND NOT QT_CONFIG___contains___static:
-# BROWSER = "qtwebkit"
-
-#### Keys ignored in scope 3:.:.:assistant.pro:else:
-# BROWSER = "qtextbrowser"
-
qt_internal_extend_target(assistant CONDITION TARGET Qt::PrintSupport
PUBLIC_LIBRARIES
Qt::PrintSupport
@@ -177,11 +167,9 @@ if(APPLE)
target_sources(assistant PRIVATE
assistant.icns
)
- # special case end
# Set values to be replaced in the custom Info_mac.plist.
set(ICON "assistant.icns")
set(EXECUTABLE "Assistant")
- # special case end
endif()
qt_internal_add_docs(assistant
doc/qtassistant.qdocconf