summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt18
1 files changed, 4 insertions, 14 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 10a33b85c..52f6589f5 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,11 +1,13 @@
-# Generated from auto.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+add_subdirectory(cmake)
if(QT_FEATURE_process AND NOT CMAKE_CROSSCOMPILING)
add_subdirectory(linguist)
add_subdirectory(qtattributionsscanner)
add_subdirectory(qtdiag)
endif()
-if(NOT CMAKE_CROSSCOMPILING)
+if(TARGET Qt::qdoc AND NOT CMAKE_CROSSCOMPILING)
add_subdirectory(qdoc)
endif()
if(TARGET Qt::Help AND NOT CMAKE_CROSSCOMPILING)
@@ -15,15 +17,3 @@ if(TARGET Qt::Help AND NOT CMAKE_CROSSCOMPILING)
add_subdirectory(qhelpindexmodel)
add_subdirectory(qhelpprojectdata)
endif()
-# special case begin
-# add_subdirectory(cmake)
-# if (TARGET Qt::Linguist)
-# add_subdirectory(cmake/linguist)
-# endif()
-# special case end
-if(QT_FEATURE_process AND WIN32 AND NOT CMAKE_CROSSCOMPILING)
- add_subdirectory(windeployqt)
-endif()
-if(MACOS AND QT_FEATURE_process)
- add_subdirectory(macdeployqt)
-endif()