summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/linguist/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/linguist/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/linguist/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/tests/auto/cmake/linguist/CMakeLists.txt b/tests/auto/cmake/linguist/CMakeLists.txt
index e137478c1..f557d134d 100644
--- a/tests/auto/cmake/linguist/CMakeLists.txt
+++ b/tests/auto/cmake/linguist/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# This is an automatic test for the CMake configuration files.
# To run it manually,
# 1) mkdir build # Create a build directory
@@ -55,6 +58,13 @@ endforeach()
include("${_Qt6CTestMacros}")
_qt_internal_test_expect_pass(test_add_translation_macro)
-if (TARGET Qt6::lupdate)
- _qt_internal_test_expect_pass(test_create_translation_macro)
+_qt_internal_test_expect_pass(test_create_translation_macro)
+_qt_internal_test_expect_pass(test_create_translation_same_base_names)
+_qt_internal_test_expect_pass(test_translation_api)
+_qt_internal_test_expect_pass(test_i18n_auto_ts_file_names)
+_qt_internal_test_expect_pass(test_i18n_exclusion)
+_qt_internal_test_expect_pass(test_i18n_filter_autogen_files)
+_qt_internal_test_expect_pass(test_i18n_source_language)
+if(NOT CMAKE_CROSSCOMPILING)
+ _qt_internal_test_expect_pass(test_i18n_subdir BINARY app1)
endif()