summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/linguist/test_i18n_auto_ts_file_names/subdir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/linguist/test_i18n_auto_ts_file_names/subdir/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/linguist/test_i18n_auto_ts_file_names/subdir/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/cmake/linguist/test_i18n_auto_ts_file_names/subdir/CMakeLists.txt b/tests/auto/cmake/linguist/test_i18n_auto_ts_file_names/subdir/CMakeLists.txt
new file mode 100644
index 000000000..2fcc3cc03
--- /dev/null
+++ b/tests/auto/cmake/linguist/test_i18n_auto_ts_file_names/subdir/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+my_add_library(lib3 STATIC ../lib.cpp)
+set(QT_I18N_SOURCE_LANGUAGE eo)
+set(QT_I18N_TRANSLATED_LANGUAGES de)
+qt_add_translations(TARGETS lib3)
+
+my_add_library(lib4 STATIC ../lib.cpp)
+set(QT_I18N_SOURCE_LANGUAGE ee)
+set(QT_I18N_TRANSLATED_LANGUAGES da)
+qt_add_translations(TARGETS lib4 IMMEDIATE_CALL)
+