summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt24
1 files changed, 7 insertions, 17 deletions
diff --git a/tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt b/tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt
index b8edeaa8e..520fbe111 100644
--- a/tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt
+++ b/tests/auto/cmake/test_uiplugin_via_designer/CMakeLists.txt
@@ -1,25 +1,15 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-# Backward compatibility test that code prior to Qt 5.5 linking to
-# Qt5::Designer gets the required include directories for using
-# the QDesignerCustomWidgetInterface.
-
-cmake_minimum_required(VERSION 2.8.11)
+cmake_minimum_required(VERSION 3.16)
project(test_uiplugin_via_designer)
-find_package(Qt5Widgets REQUIRED)
-find_package(Qt5Xml REQUIRED)
-find_package(Qt5Designer REQUIRED)
+find_package(Qt6 COMPONENTS Widgets Xml Designer REQUIRED)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-if (NOT CMAKE_VERSION VERSION_LESS 3.0)
- set(CMAKE_HAS_INTERFACE 1)
-else()
- set(CMAKE_HAS_INTERFACE 0)
-endif()
-add_definitions(-DTEST_UIPLUGIN_USAGE_REQUIREMENTS=${CMAKE_HAS_INTERFACE})
+add_definitions(-DTEST_UIPLUGIN_USAGE_REQUIREMENTS=1)
-add_library(my_designer_plugin my_designer_plugin.cpp)
-target_link_libraries(my_designer_plugin Qt5::Designer)
+add_library(my_uiplugin_via_designer my_designer_plugin.cpp)
+target_link_libraries(my_uiplugin_via_designer Qt::Designer)