summaryrefslogtreecommitdiffstats
path: root/tests/auto/linguist/lupdate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/linguist/lupdate/CMakeLists.txt')
-rw-r--r--tests/auto/linguist/lupdate/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/tests/auto/linguist/lupdate/CMakeLists.txt b/tests/auto/linguist/lupdate/CMakeLists.txt
index 3342fb7d4..ee57b32f9 100644
--- a/tests/auto/linguist/lupdate/CMakeLists.txt
+++ b/tests/auto/linguist/lupdate/CMakeLists.txt
@@ -1,11 +1,16 @@
-# Generated from lupdate.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_lupdate LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
-# special case begin
if(CMAKE_VERSION VERSION_LESS "3.19" AND MSVC AND QT_FEATURE_debug_and_release)
message(WARNING "tst_lupdate will not be built in this configuration.")
return()
endif()
-# special case end
#####################################################################
## tst_lupdate Test: