aboutsummaryrefslogtreecommitdiffstats
path: root/src/components/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2024-01-30 12:00:01 +0100
committerUlf Hermann <ulf.hermann@qt.io>2024-02-07 07:13:09 +0100
commitf3402248641dadfaf47159eea9a6c3bb1fe167fa (patch)
treef09f8bb361e8e35cb73b6bb09dbe390eed76c03a /src/components/CMakeLists.txt
parentebea18ec0033c55c65d2729ec72580b7b3d2d969 (diff)
Link VKB and VKB.Settings into VKB.Components and VKB into VKB.Styles
This forces the build system to build VirtualKeyboard and VirtualKeyboardSettings first which makes their qmltypes available to subsequent build steps. Pick-to: 6.7 6.6 Task-number: QTBUG-121643 Change-Id: Ia0cdfe522d78c94eb87f7fd2cbaf6c2fdac954aa Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/components/CMakeLists.txt')
-rw-r--r--src/components/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/components/CMakeLists.txt b/src/components/CMakeLists.txt
index 1ee450ee..1343b6dc 100644
--- a/src/components/CMakeLists.txt
+++ b/src/components/CMakeLists.txt
@@ -55,4 +55,6 @@ qt_internal_add_qml_module(qtvkbcomponentsplugin
Qt::Gui
Qt::Qml
Qt::Quick
+ Qt::VirtualKeyboard
+ Qt::VirtualKeyboardSettings
)