aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt
diff options
context:
space:
mode:
authorMÃ¥rten Nordheim <marten.nordheim@qt.io>2020-04-30 13:33:26 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-12 13:14:13 +0200
commitf8db8d979afc38215f9bbfc3daaf75cfd61b5f1d (patch)
treef83922c165fa72a5e16485dc4806b1916aad8619 /src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt
parentec0a7a4a699b8d5575de765c1a2cd077e412a9b4 (diff)
Initial CMake port of QtVirtualKeyboard
This port makes sure that all the features that are currently tested in the CI are complete and that the tests pass. lipi-toolkit can't be tested since it's currently broken in qmake. Myscript wasn't tested as it is also not tested in coin and the SDK is not available. T9Write wasn't tested as the SDK is not avaialble. Removed outdated src/virtualkeyboard/styles/styles.pro. The styles seem to be in src/styles now. Change-Id: Ibba41d592c51a19dee63840c02a945ec7b1d721e Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt')
-rw-r--r--src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt b/src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt
new file mode 100644
index 00000000..1bd98c0e
--- /dev/null
+++ b/src/plugins/pinyin/3rdparty/pinyin/CMakeLists.txt
@@ -0,0 +1,66 @@
+# Generated from pinyin.pro.
+
+#####################################################################
+## BundledPinyin Generic Library:
+#####################################################################
+
+find_package(Threads REQUIRED) # special case
+
+qt_add_3rdparty_library(BundledPinyin
+ STATIC
+ SOURCES
+ include/atomdictbase.h
+ include/dictbuilder.h
+ include/dictdef.h
+ include/dictlist.h
+ include/dicttrie.h
+ include/lpicache.h
+ include/matrixsearch.h
+ include/mystdlib.h
+ include/ngram.h
+ include/pinyinime.h
+ include/searchutility.h
+ include/spellingtable.h
+ include/spellingtrie.h
+ include/splparser.h
+ include/sync.h
+ include/userdict.h
+ include/utf16char.h
+ include/utf16reader.h
+ share/dictbuilder.cpp
+ share/dictlist.cpp
+ share/dicttrie.cpp
+ share/lpicache.cpp
+ share/matrixsearch.cpp
+ share/mystdlib.cpp
+ share/ngram.cpp
+ share/pinyinime.cpp
+ share/searchutility.cpp
+ share/spellingtable.cpp
+ share/spellingtrie.cpp
+ share/splparser.cpp
+ share/sync.cpp
+ share/userdict.cpp
+ share/utf16char.cpp
+ share/utf16reader.cpp
+ DEFINES
+ QT_ASCII_CAST_WARNINGS
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_FROM_BYTEARRAY
+ QT_NO_CAST_TO_ASCII
+ PUBLIC_DEFINES
+ HAVE_PINYIN
+ PUBLIC_INCLUDE_DIRECTORIES
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Threads::Threads # special case
+)
+qt_disable_warnings(BundledPinyin)
+
+#### Keys ignored in scope 1:.:.:pinyin.pro:<TRUE>:
+# OTHER_FILES = "data/rawdict_utf16_65105_freq.txt" "data/valid_utf16.txt"
+# VERSION = "1.0.0"
+
+## Scopes:
+#####################################################################