aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/example/CMakeLists.txt')
-rw-r--r--src/plugins/example/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/plugins/example/CMakeLists.txt b/src/plugins/example/CMakeLists.txt
new file mode 100644
index 00000000..a8976f9b
--- /dev/null
+++ b/src/plugins/example/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+add_subdirectory(hwr)
+list(APPEND example_imports QtQuick.VirtualKeyboard.Plugins.Example.HWR/auto)
+
+qt_internal_add_qml_module(qtvkbexampleplugin
+ URI "QtQuick.VirtualKeyboard.Plugins.Example"
+ VERSION "${PROJECT_VERSION}"
+ PAST_MAJOR_VERSIONS 2
+ PLUGIN_TARGET qtvkbexampleplugin
+ IMPORTS
+ ${example_imports}
+ NO_GENERATE_CPP_EXPORTS
+)