aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/hunspell/module/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/hunspell/module/CMakeLists.txt')
-rw-r--r--src/plugins/hunspell/module/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/plugins/hunspell/module/CMakeLists.txt b/src/plugins/hunspell/module/CMakeLists.txt
index 5fc2c8f4..b17ab545 100644
--- a/src/plugins/hunspell/module/CMakeLists.txt
+++ b/src/plugins/hunspell/module/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## QtQuickVirtualKeyboardHunspellPlugin Plugin:
#####################################################################
@@ -5,6 +8,7 @@
qt_internal_add_qml_module(HunspellInputMethod
URI "QtQuick.VirtualKeyboard.Plugins.Hunspell"
VERSION "${PROJECT_VERSION}"
+ PAST_MAJOR_VERSIONS 2
PLUGIN_TARGET qtvkbhunspellplugin
NO_PLUGIN_OPTIONAL
DEPENDENCIES
@@ -26,8 +30,6 @@ qt_internal_add_qml_module(HunspellInputMethod
Qt::Gui
PUBLIC_LIBRARIES
Qt::VirtualKeyboardPrivate
- GENERATE_CPP_EXPORTS
- GENERATE_PRIVATE_CPP_EXPORTS
)
qt_internal_extend_target(HunspellInputMethod CONDITION QT_FEATURE_system_hunspell