aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/inputpanel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/inputpanel/CMakeLists.txt')
-rw-r--r--tests/auto/inputpanel/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/auto/inputpanel/CMakeLists.txt b/tests/auto/inputpanel/CMakeLists.txt
index 1e9184a7..2dd636ed 100644
--- a/tests/auto/inputpanel/CMakeLists.txt
+++ b/tests/auto/inputpanel/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from inputpanel.pro.
#####################################################################
@@ -10,11 +13,11 @@ file(GLOB_RECURSE test_data_glob
${CMAKE_CURRENT_SOURCE_DIR}/data/*)
list(APPEND test_data ${test_data_glob})
-qt_add_test(tst_inputpanel
+qt_internal_add_test(tst_inputpanel
QMLTEST
SOURCES
tst_inputpanel.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
TESTDATA ${test_data}
)
@@ -26,8 +29,8 @@ qt_add_test(tst_inputpanel
## Scopes:
#####################################################################
-qt_extend_target(tst_inputpanel CONDITION NOT QT_BUILD_SHARED_LIBS
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_inputpanel CONDITION NOT QT_BUILD_SHARED_LIBS
+ LIBRARIES
Qt::Svg
)