aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/CMakeLists.txt')
-rw-r--r--tests/manual/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
index a1d2a41d..861cd2ec 100644
--- a/tests/manual/CMakeLists.txt
+++ b/tests/manual/CMakeLists.txt
@@ -1,5 +1,14 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from manual.pro.
-add_subdirectory(x11vkbwrapper)
-add_subdirectory(x11vkbtest)
+find_package(X11)
+if(X11_FOUND)
+ add_subdirectory(x11vkbwrapper)
+ add_subdirectory(x11vkbtest)
+else()
+ message("Manual tests x11vkbwrapper and x11vkbtest are not built due to missing X11 lib.")
+endif()
add_subdirectory(quickcontrols2)
+add_subdirectory(startupperformance)