summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-11-10 09:58:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-11-10 14:45:08 +0100
commitcccdaadd15cb99147f1d5d9fd91015b749424f79 (patch)
tree4d3133788330e522d0b4ec9a0dcab38ed5ba2b24 /CMakeLists.txt
parentf6be90fe629813d4941487b3a162778312e82dd0 (diff)
CMake: Make Gui and some other packages optional
This allows a no-error configuration of a -no-gui Qt build. This results in skipping building qtwayland when Gui / Quick are not available. qmake does the same. Task-number: QTBUG-88343 Change-Id: I1b0140ce5e2d3cee6050077ec3373621052f0cfa Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3833e6bbe..642afabb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,11 +28,11 @@ endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
Core
- Gui
- OpenGL
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
+ Gui
+ OpenGL
Quick
)
# special case end