summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-26 17:31:20 +0100
committerKai Köhne <kai.koehne@qt.io>2022-02-08 12:29:30 +0100
commitdace5d12929ff7b19a1290f126e3df6341de887c (patch)
tree5f0fb320ff24de1ad249fa5d194bf03ce1d3903d /CMakeLists.txt
parent3a5d36f54c754f260a52130d3515a2f7234e0051 (diff)
Compile repo with warnings as errors
Let the compilation fail if new warnings are introduced for developer builds & supported compilers. Pick-to: 6.2 6.3 Fixes: QTBUG-100249 Change-Id: I5e2a169d3342646b88cbea829251e53dd38be0b3 Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c03bf628b..0007697b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,10 +10,6 @@ project(QtWayland # special case
LANGUAGES CXX C
)
-# special case begin
-# TODO: Fix warnings and remove this
-set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
BuildInternals
)
@@ -32,7 +28,6 @@ find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
OpenGL
Quick
)
-# special case end
# special case begin
# Moved above.