summaryrefslogtreecommitdiffstats
path: root/src/plugins/decorations/adwaita/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Grulich <jgrulich@redhat.com>2023-12-12 10:08:17 +0100
committerJan Grulich <jgrulich@redhat.com>2024-03-19 14:38:40 +0100
commit40116ae353fd5f40d386c5398911d1aee483bb13 (patch)
treede1c413fc39b511a0a0164032c7407108e4404c9 /src/plugins/decorations/adwaita/CMakeLists.txt
parente6f04ce6c1849009bcdc382e7e1da62afee029c8 (diff)
Add GNOME-like client-side decoration plugin
Adds a client-side decoration plugin implementing GNOME's Adwaita style. This is trying to follow GTK4 Adwaita style, using xdg-desktop-portal to get user's configuration in order to get whether a light or dark colors should be used and to get the titlebar button layout. This plugin is now used on GNOME by default, while defaulting to the original behavior for non-GNOME DEs. It depends on QtSvg used to draw titlebar buttons so in case QtSvg is not found, this plugin will not be build. [ChangeLog][QtWaylandClient][Added GNOME-like client-side decoration plugin] Fixes: QTBUG-120070 Change-Id: I0f1777c4e0aa3467dafbbae8004b594cc82f9aa0 Reviewed-by: David Edmundson <davidedmundson@kde.org>
Diffstat (limited to 'src/plugins/decorations/adwaita/CMakeLists.txt')
-rw-r--r--src/plugins/decorations/adwaita/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/plugins/decorations/adwaita/CMakeLists.txt b/src/plugins/decorations/adwaita/CMakeLists.txt
new file mode 100644
index 000000000..b318c2b8b
--- /dev/null
+++ b/src/plugins/decorations/adwaita/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## QWaylandAdwaitaDecorationPlugin Plugin:
+#####################################################################
+
+qt_internal_add_plugin(QWaylandAdwaitaDecorationPlugin
+ OUTPUT_NAME adwaita
+ PLUGIN_TYPE wayland-decoration-client
+ SOURCES
+ main.cpp
+ qwaylandadwaitadecoration.cpp
+ LIBRARIES
+ Qt::Core
+ Qt::DBus
+ Qt::Gui
+ Qt::Svg
+ Qt::WaylandClientPrivate
+ Wayland::Client
+)
+
+#### Keys ignored in scope 1:.:.:bradient.pro:<TRUE>:
+# OTHER_FILES = "bradient.json"
+