summaryrefslogtreecommitdiffstats
path: root/src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-24 16:23:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-26 09:57:22 +0000
commite4cb32970cc1111d7bce95293e6766a879a6b5f7 (patch)
treec637be5f9e9a654c949dc2ce00d60c3c97ba8f99 /src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt
parentb77269ff500e184237d523496e17639c94009ac8 (diff)
CMake: Regenerate and adjust projects after merge
Some of the changes that were needed - adjusted wayland macros due to changed target names for plugins - a few direct moc file includes, to get rid of compilation errors - Threads::Threads linking for a few tests - a few special cases for QT_FOR_PRIVATE handling because pro2cmake doesn't handle those correctly at the moment (they map to PRIVATE_MODULE_INTERFACE rather than PRIVATE_LIBRARIES) - just regenerating all projects Change-Id: I418ce91b1c69c7388d41eb22b94a93a9e80fa732 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt')
-rw-r--r--src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt b/src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt
index 179dd8db2..d074fe4ee 100644
--- a/src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt
+++ b/src/plugins/hardwareintegration/client/xcomposite-glx/CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from xcomposite-glx.pro.
#####################################################################
-## xcomposite-glx Plugin:
+## QWaylandXCompositeGlxClientBufferPlugin Plugin:
#####################################################################
-qt_add_plugin(xcomposite-glx
+qt_add_plugin(QWaylandXCompositeGlxClientBufferPlugin
+ OUTPUT_NAME xcomposite-glx
TYPE wayland-graphics-integration-client
- CLASS_NAME QWaylandXCompositeGlxClientBufferPlugin
SOURCES
../../../../hardwareintegration/client/xcomposite-glx/qwaylandxcompositeglxcontext.cpp ../../../../hardwareintegration/client/xcomposite-glx/qwaylandxcompositeglxcontext.h
../../../../hardwareintegration/client/xcomposite-glx/qwaylandxcompositeglxintegration.cpp ../../../../hardwareintegration/client/xcomposite-glx/qwaylandxcompositeglxintegration.h
@@ -16,21 +16,18 @@ qt_add_plugin(xcomposite-glx
INCLUDE_DIRECTORIES
../../../../hardwareintegration/client/xcomposite-glx
../../../../hardwareintegration/client/xcomposite_share
- LIBRARIES
- Qt::GlxSupportPrivate
- Qt::WaylandClientPrivate
PUBLIC_LIBRARIES
${CMAKE_DL_LIBS}
PkgConfig::XComposite
Qt::Core
- Qt::GlxSupport
+ Qt::GlxSupportPrivate
Qt::Gui
- Qt::WaylandClient
+ Qt::WaylandClientPrivate
Wayland::Client
X11::X11
)
-qt6_generate_wayland_protocol_client_sources(xcomposite-glx
+qt6_generate_wayland_protocol_client_sources(QWaylandXCompositeGlxClientBufferPlugin
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../../../../hardwareintegration/client/xcomposite_share/../../../extensions/xcomposite.xml
)