summaryrefslogtreecommitdiffstats
path: root/src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-24 16:23:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-26 09:57:22 +0000
commite4cb32970cc1111d7bce95293e6766a879a6b5f7 (patch)
treec637be5f9e9a654c949dc2ce00d60c3c97ba8f99 /src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt
parentb77269ff500e184237d523496e17639c94009ac8 (diff)
CMake: Regenerate and adjust projects after merge
Some of the changes that were needed - adjusted wayland macros due to changed target names for plugins - a few direct moc file includes, to get rid of compilation errors - Threads::Threads linking for a few tests - a few special cases for QT_FOR_PRIVATE handling because pro2cmake doesn't handle those correctly at the moment (they map to PRIVATE_MODULE_INTERFACE rather than PRIVATE_LIBRARIES) - just regenerating all projects Change-Id: I418ce91b1c69c7388d41eb22b94a93a9e80fa732 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt')
-rw-r--r--src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt b/src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt
index 76dee2845..c8beed397 100644
--- a/src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt
+++ b/src/plugins/hardwareintegration/compositor/xcomposite-egl/CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from xcomposite-egl.pro.
#####################################################################
-## qt-wayland-compositor-xcomposite-egl Plugin:
+## QWaylandXCompositeEglClientBufferIntegrationPlugin Plugin:
#####################################################################
-qt_add_plugin(qt-wayland-compositor-xcomposite-egl
+qt_add_plugin(QWaylandXCompositeEglClientBufferIntegrationPlugin
+ OUTPUT_NAME qt-wayland-compositor-xcomposite-egl
TYPE wayland-graphics-integration-server
- CLASS_NAME QWaylandXCompositeEglClientBufferIntegrationPlugin
SOURCES
../../../../hardwareintegration/compositor/xcomposite-egl/xcompositeeglintegration.cpp ../../../../hardwareintegration/compositor/xcomposite-egl/xcompositeeglintegration.h
../../../../hardwareintegration/compositor/xcomposite_share/xcompositebuffer.cpp ../../../../hardwareintegration/compositor/xcomposite_share/xcompositebuffer.h
@@ -18,19 +18,19 @@ qt_add_plugin(qt-wayland-compositor-xcomposite-egl
../../../../hardwareintegration/compositor/xcomposite_share
LIBRARIES
EGL::EGL
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::WaylandCompositorPrivate
Wayland::Server
X11::X11
PUBLIC_LIBRARIES
PkgConfig::XComposite
Qt::Core
+ Qt::CorePrivate
Qt::Gui
+ Qt::GuiPrivate
Qt::WaylandCompositor
+ Qt::WaylandCompositorPrivate
)
-qt6_generate_wayland_protocol_server_sources(qt-wayland-compositor-xcomposite-egl
+qt6_generate_wayland_protocol_server_sources(QWaylandXCompositeEglClientBufferIntegrationPlugin
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../../../../hardwareintegration/compositor/xcomposite_share/../../../3rdparty/protocol/wayland.xml
${CMAKE_CURRENT_SOURCE_DIR}/../../../../hardwareintegration/compositor/xcomposite_share/../../../extensions/xcomposite.xml