summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/nooutput/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-24 16:23:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-26 09:57:22 +0000
commite4cb32970cc1111d7bce95293e6766a879a6b5f7 (patch)
treec637be5f9e9a654c949dc2ce00d60c3c97ba8f99 /tests/auto/client/nooutput/CMakeLists.txt
parentb77269ff500e184237d523496e17639c94009ac8 (diff)
CMake: Regenerate and adjust projects after merge
Some of the changes that were needed - adjusted wayland macros due to changed target names for plugins - a few direct moc file includes, to get rid of compilation errors - Threads::Threads linking for a few tests - a few special cases for QT_FOR_PRIVATE handling because pro2cmake doesn't handle those correctly at the moment (they map to PRIVATE_MODULE_INTERFACE rather than PRIVATE_LIBRARIES) - just regenerating all projects Change-Id: I418ce91b1c69c7388d41eb22b94a93a9e80fa732 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/client/nooutput/CMakeLists.txt')
-rw-r--r--tests/auto/client/nooutput/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/auto/client/nooutput/CMakeLists.txt b/tests/auto/client/nooutput/CMakeLists.txt
new file mode 100644
index 000000000..e5110c0c9
--- /dev/null
+++ b/tests/auto/client/nooutput/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from nooutput.pro.
+
+#####################################################################
+## tst_nooutput Test:
+#####################################################################
+
+qt_add_test(tst_nooutput
+ SOURCES
+ ../shared/corecompositor.cpp ../shared/corecompositor.h
+ ../shared/coreprotocol.cpp ../shared/coreprotocol.h
+ ../shared/datadevice.cpp ../shared/datadevice.h
+ ../shared/mockcompositor.cpp ../shared/mockcompositor.h
+ ../shared/textinput.cpp ../shared/textinput.h
+ ../shared/xdgshell.cpp ../shared/xdgshell.h
+ tst_nooutput.cpp
+ INCLUDE_DIRECTORIES
+ ../shared
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::OpenGL
+ Qt::WaylandClientPrivate
+ Wayland::Server
+ Threads::Threads # special case
+)
+
+qt6_generate_wayland_protocol_server_sources(tst_nooutput
+ FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/text-input-unstable-v2.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/wayland.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-shell.xml
+)