summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/seatv4/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Edmundson <davidedmundson@kde.org>2021-05-05 06:54:19 +0100
committerDavid Edmundson <davidedmundson@kde.org>2021-05-10 10:07:31 +0100
commitb7e0b627e10fe2b677847e24183ea2b4e5113a32 (patch)
tree9140ccce018f4874ef79a9472fb9c93371b0148b /tests/auto/client/seatv4/CMakeLists.txt
parent689782d03747bc17c78d8e3a48f0f3eafb8e42b5 (diff)
Simplify test cmake
In each test we were recompiling the shared mock compositor. This led to a lot of difficult to maintain boiler plate as well as slowing down the build. This patch turns the shared component into an object library Change-Id: I2460d3fec312a348fe633ac271f994dd36d564c4 Reviewed-by: David Edmundson <davidedmundson@kde.org>
Diffstat (limited to 'tests/auto/client/seatv4/CMakeLists.txt')
-rw-r--r--tests/auto/client/seatv4/CMakeLists.txt23
1 files changed, 1 insertions, 22 deletions
diff --git a/tests/auto/client/seatv4/CMakeLists.txt b/tests/auto/client/seatv4/CMakeLists.txt
index f4eb28b84..31ea86b7e 100644
--- a/tests/auto/client/seatv4/CMakeLists.txt
+++ b/tests/auto/client/seatv4/CMakeLists.txt
@@ -6,30 +6,9 @@
qt_internal_add_test(tst_seatv4
SOURCES
- ../shared/corecompositor.cpp ../shared/corecompositor.h
- ../shared/coreprotocol.cpp ../shared/coreprotocol.h
- ../shared/datadevice.cpp ../shared/datadevice.h
- ../shared/mockcompositor.cpp ../shared/mockcompositor.h
- ../shared/textinput.cpp ../shared/textinput.h
- ../shared/xdgoutputv1.cpp ../shared/xdgoutputv1.h
- ../shared/xdgshell.cpp ../shared/xdgshell.h
tst_seatv4.cpp
- INCLUDE_DIRECTORIES
- ../shared
PUBLIC_LIBRARIES
- Qt::Gui
- Qt::OpenGL
- Qt::WaylandClientPrivate
- Wayland::Server
- Threads::Threads # special case
-)
-
-qt6_generate_wayland_protocol_server_sources(tst_seatv4
- FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/text-input-unstable-v2.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/wayland.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-output-unstable-v1.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-shell.xml
+ SharedClientTest
)
## Scopes: