summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/xdgshell/CMakeLists.txt
diff options
context:
space:
mode:
authorLiang Qi <liang.qi@qt.io>2020-04-27 08:51:53 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-04-29 13:51:58 +0200
commit6319bc72e2dc63175ca797ee3042955f852e008f (patch)
treec9c1c71c43394a4cd2f0f6a75df8ba6f3a2550f3 /tests/auto/client/xdgshell/CMakeLists.txt
parent00c8a79da0c80616f18329cdfc61338a2c1af7df (diff)
parent28e7d940c42c47cf039522709883ae3de9f4fb88 (diff)
Merge remote-tracking branch 'origin/5.15' into dev
Conflicts: tests/auto/client/xdgoutput/tst_xdgoutput.cpp Regenerated CMake projects. Removed duplicate wayland source in tests/auto/client/xdgoutput/xdgoutput.pro. It's still referenced via the included shared.pri file. Regenerated the CMake project to adapt to that. Otherwise the CMake project fails to configure due to duplicate rules with a error like the one below CMake Error at src/compositor/Qt6WaylandCompositorMacros.cmake:13 (add_custom_command): Attempt to add a custom rule to output tests/auto/client/xdgoutput/wayland-xdg-output-unstable-v1-server-protocol.h.rule Also use a workaround fix for configuring CMake standalone tests due to regression introduced by dd7e40b1086020f6a054957f4972720cd684 in qtbase. Change-Id: Ib364b851a1fa828c153efbf8653c9e4ef5e618cd
Diffstat (limited to 'tests/auto/client/xdgshell/CMakeLists.txt')
-rw-r--r--tests/auto/client/xdgshell/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/client/xdgshell/CMakeLists.txt b/tests/auto/client/xdgshell/CMakeLists.txt
index cab6c8825..a680575ca 100644
--- a/tests/auto/client/xdgshell/CMakeLists.txt
+++ b/tests/auto/client/xdgshell/CMakeLists.txt
@@ -11,6 +11,7 @@ qt_add_test(tst_xdgshell
../shared/datadevice.cpp ../shared/datadevice.h
../shared/mockcompositor.cpp ../shared/mockcompositor.h
../shared/textinput.cpp ../shared/textinput.h
+ ../shared/xdgoutputv1.cpp ../shared/xdgoutputv1.h
../shared/xdgshell.cpp ../shared/xdgshell.h
tst_xdgshell.cpp
INCLUDE_DIRECTORIES
@@ -27,5 +28,6 @@ qt6_generate_wayland_protocol_server_sources(tst_xdgshell
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/text-input-unstable-v2.xml
${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/wayland.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-output-unstable-v1.xml
${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-shell.xml
)