summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..c498e15b3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,49 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from qtwayland.pro.
+
+cmake_minimum_required(VERSION 3.16)
+
+include(.cmake.conf)
+project(QtWayland # special case
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt Wayland Libraries" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
+ BuildInternals
+)
+qt_internal_project_setup()
+
+if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
+ message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
+ return()
+endif()
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
+ Core
+)
+
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
+ DBus
+ Gui
+ OpenGL
+ Quick
+ Svg
+)
+
+# special case begin
+# Moved above.
+#if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
+# message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
+# return()
+#endif()
+# special case end
+if(NOT TARGET Qt::Gui)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
+ return()
+endif()
+qt_build_repo()