summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 10 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3833e6bbe..c498e15b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,9 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qtwayland.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtWayland # special case
@@ -10,16 +13,10 @@ project(QtWayland # special case
LANGUAGES CXX C
)
-# special case begin
-# TODO: Fix warnings and remove this
-set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
BuildInternals
)
+qt_internal_project_setup()
if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
@@ -28,14 +25,15 @@ endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
Core
- Gui
- OpenGL
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
+ DBus
+ Gui
+ OpenGL
Quick
+ Svg
)
-# special case end
# special case begin
# Moved above.