summaryrefslogtreecommitdiffstats
path: root/examples/wayland/custom-extension/compositor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/custom-extension/compositor/CMakeLists.txt')
-rw-r--r--examples/wayland/custom-extension/compositor/CMakeLists.txt27
1 files changed, 14 insertions, 13 deletions
diff --git a/examples/wayland/custom-extension/compositor/CMakeLists.txt b/examples/wayland/custom-extension/compositor/CMakeLists.txt
index de5eafd96..200e7766d 100644
--- a/examples/wayland/custom-extension/compositor/CMakeLists.txt
+++ b/examples/wayland/custom-extension/compositor/CMakeLists.txt
@@ -1,25 +1,20 @@
-# Generated from compositor.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
-project(custom-extension-compositor LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+cmake_minimum_required(VERSION 3.16)
+project(custom-extension-compositor)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/custom-extension/compositor")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS WaylandCompositor)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml WaylandCompositor)
+qt6_policy(SET QTP0001 NEW)
qt_add_executable(custom-extension-compositor
customextension.cpp customextension.h
main.cpp
@@ -29,10 +24,12 @@ qt6_generate_wayland_protocol_server_sources(custom-extension-compositor
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../protocol/custom.xml
)
+
set_target_properties(custom-extension-compositor PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(custom-extension-compositor PUBLIC
Qt::Core
Qt::Gui
@@ -40,7 +37,6 @@ target_link_libraries(custom-extension-compositor PUBLIC
Qt::WaylandCompositor
)
-
# Resources:
set(compositor_resource_files
"images/background.png"
@@ -55,6 +51,11 @@ qt6_add_resources(custom-extension-compositor "compositor"
${compositor_resource_files}
)
+qt6_add_qml_module(custom-extension-compositor
+ URI io.qt.examples.customextension
+ VERSION 1.0
+)
+
install(TARGETS custom-extension-compositor
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"