summaryrefslogtreecommitdiffstats
path: root/examples/wayland/custom-extension/qml-client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/custom-extension/qml-client/CMakeLists.txt')
-rw-r--r--examples/wayland/custom-extension/qml-client/CMakeLists.txt30
1 files changed, 16 insertions, 14 deletions
diff --git a/examples/wayland/custom-extension/qml-client/CMakeLists.txt b/examples/wayland/custom-extension/qml-client/CMakeLists.txt
index 7b68ecbc1..13798b96b 100644
--- a/examples/wayland/custom-extension/qml-client/CMakeLists.txt
+++ b/examples/wayland/custom-extension/qml-client/CMakeLists.txt
@@ -1,26 +1,20 @@
-# Generated from qml-client.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
-project(custom-extension-qml-client LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+cmake_minimum_required(VERSION 3.16)
+project(custom-extension-qml-client)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/custom-extension/qml-client")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS WaylandClient)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick WaylandClient)
+qt6_policy(SET QTP0001 NEW)
qt_add_executable(custom-extension-qml-client
../client-common/customextension.cpp ../client-common/customextension.h
main.cpp
@@ -30,10 +24,12 @@ qt6_generate_wayland_protocol_client_sources(custom-extension-qml-client
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../protocol/custom.xml
)
+
set_target_properties(custom-extension-qml-client PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(custom-extension-qml-client PUBLIC
Qt::Core
Qt::Gui
@@ -43,7 +39,6 @@ target_link_libraries(custom-extension-qml-client PUBLIC
Qt::WaylandClient
)
-
# Resources:
set(qml_resource_files
"main.qml"
@@ -56,6 +51,13 @@ qt6_add_resources(custom-extension-qml-client "qml"
${qml_resource_files}
)
+target_include_directories(custom-extension-qml-client PUBLIC ../client-common/)
+
+qt6_add_qml_module(custom-extension-qml-client
+ URI io.qt.examples.customextension
+ VERSION 1.0
+)
+
install(TARGETS custom-extension-qml-client
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"