summaryrefslogtreecommitdiffstats
path: root/examples/wayland/multi-screen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/multi-screen/CMakeLists.txt')
-rw-r--r--examples/wayland/multi-screen/CMakeLists.txt18
1 files changed, 7 insertions, 11 deletions
diff --git a/examples/wayland/multi-screen/CMakeLists.txt b/examples/wayland/multi-screen/CMakeLists.txt
index d9c59f3fd..2d5ac21cb 100644
--- a/examples/wayland/multi-screen/CMakeLists.txt
+++ b/examples/wayland/multi-screen/CMakeLists.txt
@@ -1,38 +1,34 @@
-# Generated from multi-screen.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(multi-screen LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/multi-screen")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
qt_add_executable(multi-screen
main.cpp
)
+
set_target_properties(multi-screen PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(multi-screen PUBLIC
Qt::Core
Qt::Gui
Qt::Qml
)
-
# Resources:
set(multi-screen_resource_files
"qml/Chrome.qml"