summaryrefslogtreecommitdiffstats
path: root/examples/wayland/qtshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/qtshell/CMakeLists.txt')
-rw-r--r--examples/wayland/qtshell/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/examples/wayland/qtshell/CMakeLists.txt b/examples/wayland/qtshell/CMakeLists.txt
new file mode 100644
index 000000000..64db8a672
--- /dev/null
+++ b/examples/wayland/qtshell/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.14)
+project(qtshell LANGUAGES CXX)
+
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
+
+qt_add_executable(qtshell
+ main.cpp
+)
+
+set_target_properties(qtshell PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(qtshell PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+# Resources:
+set(qtshell_resource_files
+ "images/background.jpg"
+ "qml/Chrome.qml"
+ "qml/CompositorScreen.qml"
+ "qml/main.qml"
+)
+
+qt6_add_resources(qtshell "qtshell"
+ PREFIX
+ "/"
+ FILES
+ ${qtshell_resource_files}
+)